Back to overview
Maintenance

Server Maintenence

Feb 20, 2026 at 6:30am UTC  –  Feb 20, 2026 at 7:30am UTC
Affected services
Server Control Panel

Resolved
Mar 8, 2026 at 3:12am UTC

Our custom theme has been fixed and installed

Updated
Feb 20, 2026 at 7:45am UTC

Maintenance has been completed. We are temporarily on the standard Pterodactyl theme while we fix the custom theme we use.

Created
Feb 20, 2026 at 6:30am UTC

We are preforming some basic maintenance on our server. Your services may be disrupted.

This should take roughly 1 hour to complete.