Back to overview
Maintenance

Server Panel Updates

Dec 09 at 10:15am EST  –  Dec 09 at 10:46am EST
Affected services
Server Control Panel

Resolved
Dec 09 at 10:46am EST

We have completed our updates. Social logins have been temporarily disabled, contact support if you need assistance logging into your account.

Created
Dec 09 at 10:15am EST

We are preforming some basic maintenance on our server panel. Your services will not be stopped.