Back to overview
Maintenance
Server Maintenance
Sep 24 at 02:19pm EDT
–
Sep 24 at 02:32pm EDT
Affected services
Server Control Panel
Resolved
Sep 24 at 02:32pm EDT
Maintenance has been completed and services restored. We apologize for the inconvenience.
Affected services
Created
Sep 24 at 02:19pm EDT
Emergency maintenance is being conducted on our server.
All Pterodactyl services will become unresponsive and unavailable during this maintenance.
Affected services